Issue
Email notifications sent from the Pega Platform and attached to the case cannot be downloaded.
Symptoms and Impact
Unable to download email. The email content displays in a popup window.
Steps to reproduce
- Open a case that has an email attachment generated from the Pega Platform application.
- Click the link to open the email attachment.
- There is no option to download the email content.
Root Cause
This is an expected behavior in the Pega Platform. There are no OOTB functionalities available for performing an extraction of the emails for use outside the Pega Platform.
Emails generated and sent from the Pega Platform are not stored as files (Data-WorkAttach-File), but rather as Data-Corr-Email class instances. Data-Corr-Email (correspondence) attachments are displayed as a pop-up element (html) as it is fetched from blob data.
Solution
An enhancement request has been logged but has not yet been assigned to a specific release. This Known Issue document will be updated with release details when the enhancement for this issue is available.
Impacted Pega Platform versions
This applies to all versions of Pega Infinity until Pega Platform '24.
References
Sending email notifications from Cases