Issue
When following localization steps to download of a package and update it with new translated values using the App Studio wizard, the translated data does not display on the portal.
After opening the rules manually in Dev Studio, it forces the sync to App Studio.
Symptoms and Impact
Importing an updated localization pack through the App Studio localization tool does not immediately reflect the update.
Steps to Reproduce
1. Run the localization of application from App Studio
2. Delete the current localization and run it again for the same locale.
3. Update some of the translations.
4. Import the updated package.
5. Test scenario in User Portal - localization does not change.
Root Cause
This is a Pegasystems defect.
The updated Rule-UI-Localization instances are imported but the last update date time of the instance is not updated which means that the instances do not get re-synced to the constellation service.
Solution
Install the respective hotfix for the Pega Platform release that you are using:
- For Pega Platform™ 23.1.1, install HFix-B1076.
- For Pega Platform 23.1.2, install HFix-B1723 .
The user can request the hotfixes from the My Support Portal by selecting the Existing Hotfix ticket type.
For more information on creating support ticket, refer to My Support Portal FAQs.
Environment
Versions fixed in
Pega Platform 23.1.3
Pega Platform 24.1.1
References
Internationalization and localization
Creating localization Rules in Dev Studio
Localizing controls that rely on Data Pages