Issue
When using the pyProcessSLA queue processor for Service Level Event processing, updates to the SLA Goal and Deadline fail.
Symptoms and Impact
The following error displays on updating the SLA times:
Unable to open an instance using the given inputs: pxObjClass = “System-Queue-ServiceLevel”, pyItemID = “<item ID hash>”
Steps to reproduce
- Switch to the pyProcessSLA Queue Processor for Service Level Event processing by setting the UseSLAQueueProcessor Dynamic System Setting to True.
- Configure a Case type with a Step/Assignment, Process, Stage, or Overall SLA.
- Create a case of the Case type and process it to a point where it will be queued for the SLA.
- Attempt to update the SLA times for the case (for example, by using the pxAdjustSLA or pxAdjustSLATimes activities or the pxAdjustAssignmentSLA flow action).
Root Cause
A defect in Pega code/rules which results in an incorrect class being used when looking for the SLA Queue item.
Solution
Update to Infinity '25. This issue is addressed in Infinity '25.
An interim workaround is to switch back to using the agent for processing by setting the UseSLAQueueProcessor Dynamic System Setting to False.