Issue
When a case is created via an email listener in a Constellation application, and the original email and its attachments are added as attachments on the case, the attachment gadget displays a loading/uploading icon when viewing the case, and the displayed file icon cannot be opened.
Symptoms and Impact
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Attachments gadget displays “Loading” or” Uploading” percentage status against the original email content.
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Attachment cannot be downloaded.
Steps to reproduce
- Create an email listener that creates new cases based on inbound emails. You can use the CreateWorkFromMail activity.
- Send an email to the email listener to create a new case.
- Open the case.
- The Attachments gadget displays a “Loading” or ”Uploading” status against the original email content.
- You cannot download the original email content attachment.
Root Cause
A defect in Pega code which omits setting values for properties .pxCreateOperator and .pxCreateOpName.
As the Attachments widget link requires those two fields during the DX API response for GET attachments, the file is inaccessible.
Solution
Update to the following Pega Platform versions containing the updated createdBy field handling for system/bot attachments:
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Pega Platform 23.1.3. See Issue #863959 in Pega Platform 23.1.3 Patch Resolved Issues.
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Pega Platform 24.1.1. See Issue # 863958 in Pega Platform 24.1.1 Patch Resolved Issues.
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Pega Platform 24.2. See Issue # 863957 in Pega Platform 24.2 Resolved Issues.