Issue
When an SLA is added inside a Split-For-Each flow, the assignment becomes corrupted. This causes the SLA processing to fail, and the queue item to be placed in the Broken Queue. .
Symptoms and Impact
SLA processing fails, and the SLA Queue item is moved into the Broken Queue.
Steps to Reproduce
1. Configure a Split-For-Each flow that contains an SLA configuration. This could be either via an assignment shape or via a timer-based Wait shape.
2. Process a work object through the flow to a point where the SLA will be set.
3. Allow the amount of time configured for the SLA to elapse.
4. SLA processing will fail, and the associated queue item will be present in the Broken Queue
Root Cause
A limitation in Pega Code or rules where the SLA operates on the Split-For-Each Page instead of the work object page.
Solution
This issue is expected behavior for the current design of Pega code or rules. An enhancement request has been entered for your issue but has not yet been assigned to a specific release.
In the meantime, please perform the following steps to mitigate the issue:
- Modify the SLA to use the option to call an escalation activity, instead of using the action.
The escalation activity will call the ResumeFlow activity with the step page set to pyWorkPage. The escalation activity will also set a retry counter that is used in the flow so it will move to an error assignment after reaching the number of retries. This additional step is needed so that the counter is set on the page list.
Environment
Versions found in
This behavior can be observed in Pega Platform version 8 and above.
Versions fixed in
This Known Issue document will be updated with release details once the product enhancement has been implemented.
References
Running multiple instances of the same Subprocess with a Split for Each shape
Setting Service-Level Agreements for Stages, Processes, and Steps