Issue
In Constellation applications hosted on Google Cloud Platform (GCP) that rely on Constellation Messaging Service (primarily Customer Service based Applications), a Messaging Service deployment version mismatch is causing the broken communication between the Pega Infinity server and the Messaging service. This breaks any functionality in the application that relies on the Messaging Service.
Affected Versions
Pega Platform 26.1.0 and 26.1.1
Pega Platform 24.2.5
Symptoms
- Constellation application features dependent on the Messaging Service fail to function as expected.
- Requests to the GCP-hosted Constellation Messaging Service endpoint fail or do not receive the expected response.
Root Cause
Constellation Messaging Service in GCP is running an old version, missing required communication updates.
Solution
If you are experiencing this issue, please open a support ticket on My Support Portal and reference this article to obtain a temporary workaround. A temporary up-to-date messaging service will be provided for use until the GCP Constellation Messaging Services are updated.