Issue
Case Archival process fails after updating to Pega Platform 24.2.3.
Symptoms and Impact
Case gets stuck on the Metadata table with Index-Failed Status during the archival process.
Steps to reproduce
- Enable Case Archival.
- Update to Pega Platform 24.2.3.
Root Cause
A defect with Pega Platform where changes made to facilitate Date Range Search functionality are not supported by the Search and Reporting service.
Solution
Apply HFix-C4722.
Request hotfixes from the My Support Portal by selecting the Existing Hotfix ticket type.
For more information on creating a support ticket, refer to My Support Portal FAQs.
This issue is planned to be addressed in a future Pega Platform release. Issues are prioritized based on impact, severity, and capacity. The specific release for the fix has not yet been determined. This section will be updated with release details when the fix for this issue is available.
As a best practice, update your Pega deployment to the latest release as explained in Keeping current with Pega.