Issue
A blank screen appears if you process assignments using the Close the Work Object option on the If an assignment is not being performed Flow Action list.
Symptoms and impact
The following symptoms occur if you select the Close the Work Object option on the If an assignment is not being performed Flow Action list to process an assignment:
- A blank screen appears after the assignment ends and no additional assignments are available.
- You are not redirected to your worklist.
Steps to reproduce
- Create a case type with at least one user action step.
- In the user action step, click Flow Action and hover over to the Action tab.
- Select the Close the Work Object option under the If an assignment is not being performed list in the Action Tab.
- Create a case for the case type and process it until the user action step with the above configuration.
Root Cause
An error in Pega’s code or rules where the function to close a work object sometimes does not work as expected.
Solution
- Update to Pega Platform 23.1.3, see Pega Platform 23.1.3 Patch Resolved Issues.
- Update to Pega Platform 24.1.2, see Pega Platform 24.1.2 Patch Resolved Issues.
- Update to Pega Platform 24.2, see Pega Platform Resolved Issues.
OR
If you are on one of the Pega Platform versions highlighted in the Version found in section, perform the following actions to avoid this problem:
- Save the OOTB Work-.AutoClose section into an application ruleset.
- Locate the below if block in the application ruleset:
3. Append the following else condition in the ruleset:
-
Save the rule.
In some scenarios, the following additional steps are also required:
- Save the OOTB Work-.AutoClose Harness rule into an application ruleset.
- Select the Structural menu and drag a Container onto the ruleform:
7. Click OK on the popup advising that the current screen layout will be changed to a regular harness:
8. Save the Harness rule.