Pega Call - Amazon Connect - Unable to make outbound calls
We are on Version 8.3 and we are using Amazon Connect CTI.
CTI Integration is working fine and we are able to receive inbound calls.
I haven't done any specific configuration for Outbound calls. When i am testing outbound calls by using "Make Call" Control, I am getting an error "Cannot dial third party destination: Phone number is invalid."
Usually, this could be linked to dial plan, but i don't see any way to configure the dial plan.
If i dial the number directly from Amazon Connect dialer, its working.
***Moderator Edit-Vidyaranjan: Updated SR details***
ROOT CAUSE
The issue is with the wrong phone number format saved and also the regular expression present in CPMMakeCall control.
RESOLUTION
1)Save phone number in valid format
ROOT CAUSE
The issue is with the wrong phone number format saved and also the regular expression present in CPMMakeCall control.
RESOLUTION
1)Save phone number in valid format
2) In CPMMakeCall control change below regular expression
function placeCall(phoneNumber){
// Strip off any non-numeric values from the Phone Number
phoneNumber = phoneNumber.replace(/[^0-9]/g, ''); to
phoneNumber = phoneNumber.replace(/[^0-9][+]/g, '');
3)”+” has added to make it skip during the phone call.