Issue
Constellation Work portal fails to load if it has references to insights that have subsequently been deleted.
Symptoms and Impact
Landing page fails with the following error:
Show Page automation error: Cannot invoke "com.pega.pegarules.pub.clipboard.ClipboardPage.getString(String)" because "insightPage" is null
In network traffic, an http 500 Internal Server Error is returned with a response similar to the following response:
{
"errorClassification": "Execution error",
"localizedValue": "Execution error.",
"errorDetails": [
{
"message": "Show Page automation error: Cannot invoke \"com.pega.pegarules.pub.clipboard.ClipboardPage.getString(String)\" because \"insightPage\" is null",
"erroneousInputOutputFieldInPage": "",
"erroneousInputOutputIdentifier": "",
"errorClassification": "",
"localizedValue": "Show Page automation error: Cannot invoke \"com.pega.pegarules.pub.clipboard.ClipboardPage.getString(String)\" because \"insightPage\" is null",
"messageParameters": []
}
]
}
The following figure illustrates the error:

Steps to reproduce
Delete an insight that is being referenced on the default landing page of the Constellation Work portal.
Root Cause
Home Landing page references an insight that has been deleted.
Solution
Update to Infinity 25.1
Work around
-
Open the configuration of the Home landing page.
-
Remove the reference to the deleted insight.
The following figure illustrates the deleted referenced insight:
