Issue
Editing conditions and When rules in App Studio cause performance problems and nodes become unresponsive. There are several areas within Pega Platform™ where this functionality can be found, including Assignment routing, decision steps and setting conditions in Pega Customer Service.
Symptoms and Impact
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App Studio screen becomes unresponsive.
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Nodes become unresponsive.
Steps to reproduce
To reproduce the issue using Assignment routing logic:
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Launch App Studio.
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Navigate to the Case Types tab and open a Case Type.
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Select a Step in the Case Type.
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In the right-hand pane, navigate to "Use business logic" and click the gear icon. The system hangs and there are multiple null pointer exceptions in the event viewer.
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Root Cause
System performance is impacted in the following scenarios:
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There is a large number of relevant records in an application.
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There are Page or Page List properties that require multiple iterations through the class structure.
Solution
The performance impact of this limitation was reduced in version starting in Pega Platform ‘24.1.
Further improvements to the Condition Builder functionality are planned in upcoming Pega Platform patch and major releases.
Perform either of the following actions to mitigate the behavior:
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Review the relevant records in the application and remove the ones that are not used.
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In Dev Studio, click Relevant Records to view the list for the selected class.
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Reduce the amount of nested fields being fetched. Apply the following local change:
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Save the @baseclass pySetWhenGadgetContext data transform rule in the your application ruleset.
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Update property "pyNestedLevels" setting value to 1
- Update property "pyFilterByContextClass" setting value to true.
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References
Configuring business conditions