Issue
Queue items are unexpectedly removed from the Agent queue.
Symptoms and Impact
landing page is missing expected queue items.
Steps to reproduce
- Open Admin Studio.
- Click > .
- Click the queue that contains the items that you want to view.
Items that were present previously are no longer in the queue.
Root Cause
Any user with Admin Studio access can remove work items from an agent queue using the “Remove All” option. Removing an item deletes it from the queue.
To confirm if this option was used, check the Pega log files for messages occurring around the time the queue items went missing:
Log Error:
2024-01-01 01:02:03,004 [ PegaRULES-Batch-1] [ STANDARD] [ ] [ MyApp:01.01.01] (Operation.System_Queue_.Action) INFO BA0BCDEFG12H3IJKLMNOP4QRS5T6UVW78X Admin@MyOrg – RemoveAllItems
Solution
If a user has removed queue items by mistake, the only option available is to reinstate them by performing a Database-level restoration.
Controlling who can perform actions on agent queues, such as the “Remove All” option, can be done by monitoring which users have the PegaRULES:SysOpsAdministrator role.
An enhancement request has been logged to request that the product provide more information when the “Remove All” option is used, both during and after its use.
This Known Issue document will be updated with release details when the enhancement for this issue is available.