Issue
After updating to Infinity™ release 24.2, users see errors when running Pega GenAI Coach™.
- SQL State exceptions during status calls
- UI Exceptions when running the Coach widget
- “An unexpected error occurred while retrieving documents from the vector store” in the log files.
Symptoms and Impact
Coach is a licensed feature and is supported only when the Autopilot ServiceBaseURL DSS is enabled. Users on CloudK and PEGA Labs have reported the below symptoms:
- In Utilities view you see error message: “"Error while deploying the assistant"
- In Full view you see warning that widget is deprecated. When configuring GenAI coach in Tabs in Full View you can see information: "This version of the GenAI Coach widget is deprecated. Please reconfigure it by either adding the new version of the GenAI Coach widget or using the "GenAI Coaches" configuration available in Full Object Views."
Coach, Analyze, and Automate GenAI products and capabilities are available with Pega Infinity 24.1™ and above and can be purchased as a Pega GenAI Bundle.
GenAI Assistant service sits behind the scenes and helps power Coach and Autopilot. It also normalizes APIs between model providers to let you switch between models across providers on the Connect GenAI rule in 24.2.
Any problems with the GenAI Assistant Service will affect these GenAI components.
Steps to reproduce
1. Create new Constellation application using Pega GenAI Blueprint™.
2. Import application zip into Pega Community Edition.
3. Enable GenAI (check with your CSM or Account Executive to obtain the necessary license).
For more information, see Connecting to the generative AI provider in Pega Cloud.
4. In App Studio click
Tab > >GenAI Coaches5. Click on pyGenAICoachDefault) to a Case type.
icon to add default GenAI coach (See reference Enabling Pega GenAI Coach in a Case Type or Data Object
6. Create a case and check GenAI Coach to start conversation.
7. Launch Coach. Error appears.
Trace
Error
2025-01-20 05:37:02,963 [ PegaRULES-Batch-5] [ STANDARD] [ ] [ Appointm:01.01.01] ( internal.mgmt.Executable) ERROR BW61ZLN84S5K85EZYPWMOT47J5K2DFIETA user - API usages counter failed for :: Appointm_C11N_USAGE
2025-01-20 05:37:12,370 [ttp-nio2-8080-exec-2] [ STANDARD] [ ] [ Appointm:01.01.01] (nai.autopilot.AutoPilotService) ERROR pega-pega-pega-djdpw|xxx.xx.xx.xx|Rest|application|v2|assistants_var_conversationsbd8f407531730148c142e04c99eb9a6e|A2D3AB5495CF840DA3F0DF934BE8CB8D7A HOMPLCNO58DVLEII3P75DY36OXOYADOLHA user - Call to autopilot upload API failed with error body: {"title":"Internal Server Error","detail":"An error occurred while uploading documents to the vector store: Cannot connect to host xxx.xxx.xx.x:8080 ssl:default [Connect call failed ('xxx.xxx.xx.x', 8080)]","errorCode":"AP-400-001"}, error code: AP-400-001, error message: An error occurred while uploading documents to the vector store: Cannot connect to host xxx.xxx.xx.x:8080 ssl:default [Connect call failed ('xxx.xxx.xx.x', 8080)]
Root Cause
New versions of the Python package can break Assistant framework functionality. The Vector Store cannot find the mandatory collections, causing SQL exceptions.
Solution
A new release of autopilot-service, containing changes related to these issues, has been released.
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If you do encounter an issue, please create a support incident via the MSP in order that our Cloud team can apply a fix and restart the autopilot-service pods.
References
Enabling Pega GenAI in Pega Cloud
Pega GenAI Coach in Case Management