Issue
The Submit button on the Multi-factor authentication login page does not respond when clicked.
Symptoms and Impact
After updating to Pega Platform 23.1.3, when user credentials are entered on the MFA login screen, a prompt appears, requiring a one-time password (OTP). However, after submitting the OTP, no response is returned, and the MFA and login cannot be completed.
Steps to reproduce
- Navigate to the username and password input fields in the Pega Platform 23.1.3 login screen.
- Enter credentials and click Log in.
- A prompt is displayed requiring an OTP.
- Enter the correct OTP and click Submit.
Result: The Submit button does not respond and the MFA login cannot be completed.
Root Cause
A defect in Pega’s code or rules modifies the HTML code on the Multi-factor authentication OTP screen leading to issues with the Submit button functionality.
Solution
Update to the following Pega Platform versions with the fix:
- Pega Platform 23.1.3, see Pega Platform 23.1.3 Patch Resolved Issues.
- Pega Platform 24.1.1, see Pega Platform 24.1.1 Patch Resolved Issues.
- Pega Platform 24.1.2, see Pega Platform 24.1.2 Patch Resolved Issues.
- Pega Platform 24.2, see Pega Platform 24.2 Resolved Issues.
OR
Apply HFIX-B2384 on Pega Platform 23.1.3. This HFIX updates the HTML code that caused the problem.