Issue
For a Fraud/Authorization Error Dispute, when issuer withdraws Arbitration from Arbitration Acknowledgement assignment and performs a submit, an error occurs indicating invalid combination of VisaCaseNumber and DisputeFilingItemId.
In the Visa Allocation Flow, Visa places both Arbitration and Arbitration Acknowledgement Batch Queue Records in the correct sequence order within the queue. However, an issue is observed in the processing order of these Batch Queue Records by the Pega Queue Processor.
In certain scenarios, the Queue Processor processes the Arbitration Acknowledgement Batch Queue Record before the Arbitration Batch Queue Record, even though they are placed sequentially by Visa. As a result, the case bypasses the Awaiting Arbitration Acknowledgement flow, and Arbitration‑specific mappings (including Arbitration ID) are not applied as expected.
This incorrect processing order leads to failures during Arbitration withdrawal, and Arbitration details display incorrectly in the case.
Error
{ "Status":[ { "Code":"E-900000017" ,"Message":"Invalid combination of VisaCaseNumber and DisputeFilingItemId." } ] }
Steps to Reproduce
- Create a Fraud/Authorization Error Dispute.
- Process the case till the arbitration acknowledgement stage.
- Open the Arbitration Acknowledgement assignment.
- Select the option.
- Click .
Root cause
The root cause is a process gap in the queue processing mechanism. Visa places Arbitration Batch Queue Records and Arbitration Acknowledgement Batch Queue Records in the INCOMING_BQ_ARBITRATIONS queue in sequence order. However, in some scenarios, the Queue Processor processes the second Batch Queue Record (Acknowledgement) first, causing the case to bypass the Arbitration Acknowledgement processing path. This leads to Arbitration-related mappings being missed, resulting in issues during Arbitration withdrawal. Additionally, in some cases, the Acknowledgement Batch Queue Record is not received from Visa, causing cases to remain stuck in Awaiting Arbitration Acknowledgement.
Solution
Perform the following local-change to address the issue:
Rules to be created
1)Create property, IsDirectAcknowledgementFromBQ (PegaFSPE-Work-Exception-Card-Visa)

2)Create data transform, GetDisputeFilingItemId (PegaFSPE-Work-Exception-Card-Visa)

3)Create data transform, SetArbitrationIdFromHyperSearch (PegaFSPE-Work-Exception-Card-Visa)

4)Create class, PegaFSPE-Data-Service-Visa-SI-PredictionHistories

Note - Not related to above issue (Internal dependency bug in Hyper Search Mapping)
Rules to be updated
1)Update flow, AwaitingArbitrationAcknowledgement (PegaFSPE-Work-Exception-Card-Visa)




2)Update data transform, GetDisputeFilingDetailsOperationReq (PegaFSPE-Work-Exception-Card-Visa)

3)Update data transform, MapArbitrationDetails (PegaFSPE-Work-Exception-Card-Visa)
