Issue
The pyProcessSLA queue processor generates broken queue items and BadInputException errors when the associated assignment is no longer available during processing. This issue does not impact workflow processing.
Symptoms
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Broken pyProcessSLA queue items with errors such as “Unable to open an instance using the given inputs”, referencing the related assignment with the queue item.
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BadInputException errors on instances of the System-QueueProcessor-DelayedItem class when attempting to complete an assignment.
Steps to reproduce
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Perform an action on a work object that queues one of its assignments to the SLA queue processor.
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Attempt to process the same assignment within the SLA-defined timeframe.
Root Cause
A defect in Pega’s code or rules which results in:
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SLA queue items to be processed after its assignment is removed.
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Assignments to be processed after its delayed queue item is removed.
Solution
Since this issue does not affect workflow processing,
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Errors associated with this issue can be ignored.
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Broken queue items associated with this issue can be deleted.
Workaround
If you are on Pega Platform 25.1.2, apply HFIX-D836. This hotfix helps prevent the creation of broken queue items.
You can request this hotfix through the My Support Portal by selecting Existing Hotfix as the ticket type. For details on creating a support ticket, refer to the My Support Portal FAQs.