Issue
On updating to Pega Platform™ 23.1.2, backward compatibility issues occur with use cases that are in the case Change stage.
Symptoms and Impact
The issue is observed while executing a Change stage operation. Since the cases remain in the same/current stage and do not proceed to the next stage, the operation fails.
Steps to Reproduce
- Configure a multistage process.
- Add an assignment to one of the stages.
- Add an action that moves between different stages.
- Create and process a case through an assignment and Change stage. The case should move to the next stage. However, the case remains in the current stage.
Root Cause
This is a Pegasystems defect where a new stage history record was being added instead of updating the existing stage history record.
Solution
Perform either of the following:
- Install HFix-B1353 to mitigate the issue in Pega Platform 23.1.2.
The user can request the hotfixes from the My Support Portal by selecting the Existing Hotfix ticket type.
For more information on creating a support ticket, refer to My Support Portal FAQs. - Update to:
- Pega Platform 23.1.3
- Pega Platform 24.1.1
- Pega Platform 24.2