Issue
After updating to Pega 24.2.2 an incorrect message displays in the Case Audit History.
Symptoms and Impact
History entries for manual and automatic assignment and stage transitions which in earlier releases displayed "complete Task", now display "has replied to a comment on a case that you are following."
Steps to Reproduce
This behavior can occur in multiple scenarios, including, but not limited to:
- Routing an assignment to an operator or workbasket.
- Allowing the Goal or Deadline time of an Assignment Service-Level Agreement (SLA) to pass.
Routing an Assignment:
- Log in to the end-user Portal.
- Find and double click the Case that you want to open.
- In the Tools section, click Actions > Transfer Assignment.
- In the Activities pane of the Case, in the Transfer Assignment section, select the new assignee.
- Click Transfer.
- Open the case.
- Look for the 'History' option within the case details interface - this may appear as a 'History' tab, ' ' button, or similar option in the case menu.
Assignment SLA:
- In the navigation pane of App Studio, click Case Types, and then click the Case Type that you want to open.
- Configure a Case type with a Step/Assignment SLA.
- In the upper-right corner of the Workflow tab, click Lifecycle.
- In the Case Lifecycle section, click the element of a Case Lifecycle for which you want to define an SLA.
- In the Properties pane, click Goal & deadline.
- In the Use Service-Level Agreement (SLA) list, select the SLA criteria.
- In the Goal section, define custom SLA criteria for the goal.
- In the Deadline section, define custom SLA criteria for the deadline.
- Click .
- Log in to the end-user Portal.
- Create a case of the Case type and process it to a point where it will be queued for the SLA.
- Process a case until it reaches the defined scope of the SLA.
- Allow Case processing time to elapse.
- Open the case.
- Look for the 'History' option within the case details interface - this may appear as a 'History' tab, ' ' button, or similar option in the case menu.
Root Cause
A defect in Pega rules where the out-of-the-box field value for the rule pyInstructions.complete task is set to “has replied to a comment on a case that you are following.”
Solution
Changes to address this defect are planned but have not been assigned to a specific release. This known issue document will be updated when a release with a fix is available.
In the interim, the text for the field value rule pyInstructions.complete task can be changed to “complete task” and the rule can be saved into an application ruleset.
References
Setting Service-Level Agreements for Stages, Processes, and Steps