Issue
After updating to Pega Platform 25.1.x, case processing fails with the following database save error:
Cannot save instance of class Index-PEG-FW-TSTFW-Data-InternalRequest; it belongs to fully exposed table pegadata.pr_Index_PEG_FW_TSTFW_Data in database PegaDATA, but the instance has properties which do not correspond to columns: UpdateDateTime
Symptoms and impact
The database save error can reference the following properties:
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UPDATEDATETIME
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INSTANCEKEY
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UPDATEOPERATOR
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STATUSLABEL
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STATUSWORK
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STATUS
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CREATETIME
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CATEGORY
Although the error commonly references the UpdateDateTime property, any Deployment Manager–defined property with a generic name in @baseclass can cause a conflict with another version of the property provided by the client application or another strategic application.
Steps to reproduce
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Update your application to Pega Platform 25.1.x.
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Attempt to process cases using Deployment Manager.
You will observe case-processing failures with property-to-column mismatch errors.
Root cause
Some Deployment Manager versions define properties in @baseclass that conflict with properties defined higher in the class hierarchy. In 25.1.x, stricter validation of exposed database tables causes these conflicts to result in runtime errors.
Solution
Run the DeleteDMRule activity to remove Deployment Manager properties defined in @baseclass.
For more information, see Deployment troubleshooting FAQs.