Issue
Enabling the ‘auto-save’ option for forms on a ‘Case Type’ within a password-protected application does not automatically save the forms.
Steps to reproduce
-
Navigate to the ‘Security’ tab of the application Rule, select the required password to update the application, and save the Rule.
-
Override the ‘pyEnableAssignmentFormAutoSaveFlag’ When Rule in the application ruleset and configure it to always return ‘true.’
-
In the ‘Settings’ tab of the ‘Case Type’, select the checkbox labeled ‘Auto-save assignment form changes regularly when a user isn’t typing.’
Root Cause
This error occurs due to a limitation in Pega’s code or Rules.
Solution
An enhancement request has been raised for this issue but has not yet been assigned to a specific release.
Workaround
In the interim, temporarily disable password protection on the application Rule to enable the ‘auto-save’ option using the ‘Case Type’ settings. This step is only required when selecting the checkbox using the ‘Case Type’ settings. Once 'auto-save' is enabled, password protection can be re-enabled on the application Rule.