Issue
During Wait step processing, case updates sometimes do not persist on parent cases if the Wait step is configured with the Wait for (Case type) list.
Symptoms and Impact
The pyTopCasePage is not removed from the clipboard if the Wait step is configured with the Wait for (Case type) list during Wait step processing with case dependency. As a result, case updates are sometimes not reflected on the parent case.
Steps to reproduce
- Add a Wait step to the lifecycle of your Case Type.
- In the Wait type list, select Case Dependency.
- Leave the Wait for all child cases to be resolved checkbox unchecked to invoke the Wait for (Case type) list.
- Create a case for the Case Type and progress the case through its lifecycle until it reaches the Wait step.
- Create a case for the dependency Case Type and progress the dependency case to a point where the waiting case resumes.
- Updates to the waiting case are sometimes not reflected.
Root Cause
A defect in Pega code or rules that doesn’t remove the pyTopCasePage from the clipboard during Wait step processing. The pyTopCasePage and case processing page have the same value for the pzInsKey property. This causes the updates to a waiting case to be sometimes incorrectly added to the pyTopCasePage , leading to the problem.
Solution
As a workaround to this problem, follow the below steps:
- Add a Wait step to the lifecycle of your Case Type.
- In the Wait type list, select Case Dependency.
- Select the Wait for all child cases to be resolved checkbox. The Wait for (Case type) list is not displayed if this checkbox is checked.
- Create a case for the Case Type and progress the case through its lifecycle until it reaches the Wait step.
- Create a case for the dependency Case Type and progress the dependency case to a point where the waiting case resumes.
- Updates to the waiting case are correctly displayed.
This issue is planned to be addressed in a future Pega Platform release. Issues are prioritized based on impact, severity, and capacity. The specific release for the fix has not yet been determined. This section will be updated with release details when the fix for this issue is available.
Environment
Version found in
This problem occurs in the following Pega software versions:
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Pega Platform™ 8.7.6
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Pega Platform 8.8.4