Issue
Search icon in the User portal is unresponsive after updating to Pega Platform 25.1. However, on using the Enter key, Search functionality displays the results.
Symptoms and Impact
Search icon is unresponsive.
Steps to reproduce
- Launch the User portal.
- Enter the case Id.
- Verify if the Search icon is responsive.
Root Cause
In versions before Pega Platform 25.1, the Search icon was on the left side of the header. From Pega Platform 25.1, the ThemeCosmos redesign implemented a UI/UX update moving the Search icon to the right side of the header. This is a product-level design change, not a defect. The client attempted to override this behavior by customizing the WorkSearchGadget rule, leading to misalignment with the new UX pattern potentially causing unintended UI inconsistencies or functional issues.
Solution
Pega does not recommend moving the Search icon in the Work Search gadget section (OOTB) to the left side through customization, as it goes against the updated UX pattern and can cause unexpected UI issues.
Pega recommends to continue using the OOTB configuration provided by the platform to ensure proper functionality and compatibility.