Overview
The Customer Decision Hub engineering team has discovered a product defect in 1:1 Operations Manager that leads to incorrect rule updates when conflicts are presented during the deployment of a revision. The system incorrectly updates the revision package when the user clicks on the “Resolve automatically” button (see image below).
This defect affects 1:1 Operations Manager on Infinity versions 8.8.x, 23.x and 24.1. Pega is proactively notifying clients since this issue could lead to runtime errors and incorrect offer presentation in production.
What is conflict checking during revision deployment?
When changes occur at the same time in Standard and Fast releases, changes may update the same shared artifact such as Decision data rules (i.e. DDR) or Next Best Action Designer configuration rules. The feature intends to detect these conflicts in DDRs, Proposition Filters, and other rule types, and provide a warning to prevent incorrect data from being deployed to production. A conflict message will appear during the revision deployment of the release that doesn't have the latest changes deployed. However, some clients have reported that conflicts occur even though they are not using the Fast release feature.
Issue 1:
Incorrect conflicts are detected even though the client is not using the Fast Release feature to deploy parallel changes.
Root cause:
False conflicts are being detected in artifacts that undergo multiple revisions (updates) within a single release. When a rule undergoes multiple updates through Standard change request, conflicts arise due to discrepancies in the "pxMergeSynchronized" property value compared to the deployed version's "pxUpdateDateTime" in the "pySaveRMRuleToBranch" activity.
Steps to Replicate:
- A user selects a WHEN rule in a standard change request in the CDH portal using Revision Management. User resolves the change request.
- The same steps are repeated to edit the same WHEN rule multiple times in multiple standard change requests in the same open revision.
- Proceed with deployment, during this process, the conflict screen will present the WHEN rule as a conflict.
- Note: This issue can occur with other rule types updated via standard change requests and it is not restricted to WHEN rules.
Resolution:
- All clients are advised to disable the Conflict Check screen in the Revision Deployment process. Please see the FAQ below for the steps to disable the screen.
- Earlier we advised clients on Pega Infinity 23.x to apply HFIX-B1693. If you have already applied this hotfix, please be advised that this only partially resolves the problem. As such please disable the Conflict Check screen.
- Note: Merge conflicts may still occur in the Development environment during the pipeline execution. These conflicts are separate from the Conflict Check screen. These rule merge conflicts need to be evaluated and resolved manually in the Development environment.
Issue 2:
Incorrect rule updates after automatically resolving conflicts using the "Resolve automatically" option.
Root cause:
When shared rules exist between Standard change request and 1:1 Ops manager change requests (OpsCR), we have observed that conflicts are not accurately identified for these shared rules, resulting in the deletion of some rules. Shared rules include Decision Parameters (DDRs), Proposition Filters, and WHEN rules.
Steps to Replicate:
- During the standard release, use OpsCR to update an action and include 2 Email treatments and 2 Web treatments.
- Confirm that the Email Treatments DDR shows increases in the row count (e.g., 24 existing + 2 new rows for new treatments) in the branch, and the Web Treatments DDR includes newly added treatments (76 existing + 2 new rows for new treatments).
- Resolve the OpsCR.
- Create a Standard CR and update the Email Treatments DDR and Web Treatments DDR. Add new form fields to the DDRs. Complete the Standard CR.
- Create a Fast release, update an action using OpsCR, and add 2 Email treatments and 2 Web treatments.
- Deploy the Fast release.
- Before deploying the revision of the standard release, encounter the same conflict screen. Upon clicking "Resolve automatically," the Email Treatments DDR was deleted from the branch, and the Web Treatments lost the 2 new treatments.
Resolution:
- All clients are advised to disable the Conflict Check screen in the Revision deployment process. Please see the FAQ below for the steps to disable the screen.
- For clients using Fast Release, please replicate the business changes completed in a Fast Release into the next Standard release. The feature that automatically merges changes from Fast Release to Standard release is now disabled.
- For example, if an Action called "Cash bonus on savings" was deactivated in the Fast Release but remains active in the Standard release, you must apply this change across both releases to maintain consistency and avoid potential business conflicts.
Frequently Asked Questions:
Question | Response |
---|---|
What is Fast Release? | A feature introduced in version 8.8 to enable a parallel revision for quickly deploying action defects to production. |
Should I disable this feature if I am not using the Fast Release feature? |
Yes, this is the recommendation. To disable this feature please refer to Resolve artifacts conflicts (pega.com) For release 8.8.x, please install HFIX-B493 and use the DSS DISABLEREVISIONCONFLICTS. For release 23.x, please install HFIX-B1251 and use the DSS DISABLEREVISIONCONFLICTS. For release 24.1.x, please install HFIX-B1953 and use the DSS DISABLEREVISIONCONFLICTS. |
Is there an alternative method to manage conflicts if I intend to use parallel releases? |
If you introduce a business conflict across a Standard release and a Fast release, then you must review your data and resolve the issue manually. For example, if the action "Cash bonus on savings" has been deactivated in the Fast release, but remains active in the Standard release, its your responsibility to maintain consistency by ensuring that both copies remain the same. |
What are Pega’s plans for this feature going forward? |
Pega will be enhancing this feature in upcoming releases to automatically resolve business conflicts. Pega will not be fixing this defect in version 24.2 or earlier. Clients are advised to follow the documentation to resolve conflicts manually, that arise from using Fast Release. |