Issue
Initialization or execution failures occur when creating, deploying, or running a new or custom Queue processor (QP).
Symptoms and Impact
Symptoms and errors include, but are not limited to, the following:
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Queue processors fail to start in production environments.
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The following error is returned when enabling a queue processor:
- Queue processor: [QP name] couldn't move to RUNNING Current status: FAILED
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The system cannot find the configuration instance for queue processor [QP name] in memory.
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Hazelcast (HZ) SystemPulse feature crashes.
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HZ SystemPulse feature is inactive on some nodes
Steps to reproduce
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Deploy a new Queue Processor rule or create a new Queue Processor instance.
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Run the newly created Queue Processor rule or queue processor instance from Admin Studio.
The Queue Processor will display a Failed status instead of the expected Running status.
Root Cause
The root cause is currently unknown and Pega is investigating to isolate the problem.
This Known Issue document will be updated when the root cause is determined.
Solution
Migrating to external Hazelcast might not resolve the issue. Until the root cause is isolated, Pega recommends enabling the log category with SystemPulse on DEBUG (embedded or external Hazelcast) and collecting the logs daily. If the issue recurs, Pega can utilize the logs to isolate the problem.
Workarounds
For Pega Cloud clients: Pega DBAs can perform either of the following:
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Delete the QP dataflow items and metadata, then restart the background processing nodes.
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Simply restart the background processing nodes to see if it helps start the QP.
For On-Prem & Client Cloud clients: The client’s DBAs must delete the QP data-flow items and metadata, then restart the data Util nodes.