Issue
When Field-level Auditing is enabled on the case status and the case status is changed, the new status value does not display in the field history. However, the old value displays.
Symptoms and Impact
After the case status is changed, the new value is not displayed along with the old value in the field history.
Steps to Reproduce
- Log in to the Pega application.
- Create a case type.
- Enable Field-level Auditing on the case status for that case type.
- Configure a step In the case life cycle that changes the case status.
- Create a case of that case type.
- Progress the case through to the step that changes the case status.
- Review the field history.
Root Cause
This is a Pegasystems defect. The new value was present on the D_pxFieldHistory
data page. However, the non-autogenerated code prevented the value from being displayed.
Solution
Update to either of the following:
- Pega Platform™ 8.7.5
- Pega Platform 8.8.2
- Pega Platform 23
Environment
Version found in
The problem was reported in the following environments:
- Pega Platform 8.7.1
- Pega Platform 8.7.4
Version fixed in
- Pega Platform 8.7.5
- Pega Platform 8.8.2
- Pega Platform 23