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Capgemini Sverige AB
SE
Last activity: 23 Jan 2017 1:38 EST
Some times StatusWork is still showing as "In Progress" instead "Complete" though all the child objects are "Resolved"
Hi,
In my application, status is still showing as "In Progress" in some cases even if all the child objects are resolved (it'll change to Complete usually). I have added the log message to track the status changes, i could find the status changed to "Complete" from "In Progress", but couldn't find the status changed to "In Progress" again. It's showing as "In Progress" in Portal and Database.
Any suggestions on what could be the reason/ways to track down more?
Thanks,
Srini
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Pegasystems Inc.
IN
For portal, have you tried refreshing the case and check ?
Also, are you using a kind of ticket ( e.g AllCoveredResolved ) to resolve parent case automatically when all child cases are resolved ?
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Capgemini Sverige AB
SE
Hi Santanu,
Yes, i have tried refreshing in portal. Usually it gets changed to "Complete" when we refresh, but in these cases it's not changing to "Complete" even after doing Refresh.
Yes, we are using AllCoveredResolved to resolved parent case.
Actual issue here is, Logs saying that the status has been changed to Complete but neither Database nor protal showing that in these cases.
Thanks,
Srini
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Pegasystems Inc.
IN
Hello
Can you try tracing and see whether the save / commit of the parent item is happening properly or not ?
Also what is the status that you are trying to set ? Is it Resolved-Complete ?
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Pegasystems Inc.
IN
Hi All,
I had a case with similar issue. Please check below things if that is the cause in your case as well.
SUMMARY
Cases are not getting Resolved, though all the tasks are in Resolved-Complete State. In the Application, the "Resolved" Status is camel case.
ERROR MESSAGES
Not Applicable
STEPS TO REPRODUCE
Create a parent case
Create several child case under the parent case.
Set status of parent case to be resolved if all child cases are in resolved state.
Resolve child cases under parent case.
ROOT CAUSE
UnresolvedWorkInACover listview rule has a condition that checks .pyStatusWork does not start "RESOLVED"
RESOLUTION
Check IgnoreCase checkbox in the rule to avoid comparing case missmatch.
![](https://accounts.pega.com/sites/default/files/pega-user-image/248/REG-247595.png?source=PUMINIT)
![](https://accounts.pega.com/sites/default/files/pega-user-image/248/REG-247595.png?source=PUMINIT)
Capgemini Sverige AB
SE
Hi Senaj,
It looks closer to my issue, however i couldn't find IgnoreCase checkbox in UnresolvedWorkInACover listview rule. Can you please suggest which tab has it and which version you are saying about?
and as per your Route cause, is it because of case sensitive issue?
Thank you,
Srini
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Pegasystems Inc.
US
Hi Srini,
Could you try the below PDN article change,
https://community.pega.com/support/support-articles/cases-not-getting-though-tasks-resolved
In the UpdatedRecentlyByMe > Content tab > pxUpdateDateTime field need to be checked with ignore case checkbox.Let me know if you still need further help.
Regards,
Mahesh
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Capgemini Sverige AB
SE
Hi All,
Sorry for late reply, Ignore Case checkbox is already checked in "UnresolvedWorkInACover" list view rule.
Thanks,
Srini
![](https://accounts.pega.com/sites/default/files/styles/user_image/public/1689979000/321c2db9-adc7-4c43-8f1d-d6a84c486e5a.jpg?itok=mEyE0RUn)
![](https://accounts.pega.com/sites/default/files/styles/user_image/public/1689979000/321c2db9-adc7-4c43-8f1d-d6a84c486e5a.jpg?itok=mEyE0RUn)
Pegasystems Inc.
US
Hi Srini,
As per the above support article you need to check the .pxUpdateDateTime property IgnoreCase checkbox in the UpdatedRecentlyByMe List View rule not UnresolvedWorkInCover rule.
Regards
![](https://accounts.pega.com/sites/default/files/pega-user-image/248/REG-247595.png?source=PUMINIT)
![](https://accounts.pega.com/sites/default/files/pega-user-image/248/REG-247595.png?source=PUMINIT)
Capgemini Sverige AB
SE
Hi Mahesh,
Above article does saying to check IgnoreCase checkbox in "UnresolvedWorkInACover" listview rule, however it's already checked in my application.
If i have to update IgnoreCase checkbox for property .pxUpdateDateTime in "UpdatedRecentlyByMe" List view rule, could you please tell me how it works? If it's causing the issue, it should have causing the same issue for every Case but it's happening for only few cases.
Thanks,
Srini