Executive Summary
This issue relates to Pega Customer Decision Hub (CDH) for clients on release 25.1 and later.
The issue occurs in Concurrent Change Management (CCM). It can impact the correct evaluation of eligibility rules for external Email and SMS treatments.
Remediation: Affected Clients are advised to apply the hotfix outlined below.
Overview
In certain scenarios, inconsistencies may arise between treatment configuration records and their associated eligibility definitions during creation or update of treatment eligibility. As a result, the runtime treatment selection logic may continue to evaluate an older or unintended eligibility configuration, even after changes are made.
This can cause eligibility rules to not be enforced as expected and may lead to unintended treatment selection.
How to determine if you are affected
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You use Customer Decision Hub version 25.1 or later
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You use Concurrent Change Management (CCM)
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You create or update eligibility rules for external Email and/or SMS treatments
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You expect updated eligibility configurations to be enforced at runtime
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Description |
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Problem Statement |
When creating or updating eligibility rules for external Email or SMS treatments, the system may persist inconsistent eligibility configurations across treatment records. |
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Root Cause |
Eligibility configuration records and associated eligibility definitions are not consistently aligned during eligibility creation or update, resulting in duplicate or incomplete eligibility entries. |
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Resolution |
The fix ensures consistent creation and update of eligibility definitions and treatment configuration records, preventing mismatches and ensuring correct runtime eligibility evaluation. |
Impact Summary
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Eligibility updates for external Email and SMS treatments may not take effect at runtime
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System may continue to select treatments using outdated eligibility configurations
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Risk of unintended treatment delivery constitutes an Action Safety concern
Obtaining your hotfix
Please review the following hotfixes and take appropriate action. Note: A restart is not required after applying the hotfix
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HFIX ID |
Pega CDH Version |
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HFIX-D994 |
25.1.1 |
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HFIX-D1054 |
25.1.2 |
If you are a Pega Cloud client, your Pega Cloud® environments are being updated with the hotfix by Pega. Cloud Maintenance (CM) cases are being created for each of your environments, which provides the schedule of when the hotfixes will be applied.
If you are a United States Pega Cloud for Government (PCFG) client, Cloud Change (CC) cases are being created for the hotfix, which will be applied by Pega.
If you are an on–premises or client managed cloud client, please submit a hotfix request using My Support Portal. As always, be sure you have appropriate backups in place before applying the hotfix.
For any questions, contact Global Client Support via My Support Portal.